Paypal payments affected
Incident Report for
CleverReach
Resolved
The problem has been resolved, Paypal payments work again
Posted
Sep
16
,
2026
-
08:56
CEST
Identified
Currently paypal payments are affected.
Issue has been identified and a workaround is being deployed.
Posted
Sep
15
,
2026
-
09:25
CEST
This incident affected: Payments (other).
×
Subscribe to Incident
Subscribe to updates for
Paypal payments affected
via . You'll receive .